Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-56430

Processor configuration not saved

    XMLWordPrintable

Details

    • Bug
    • Resolution: Fixed
    • Blocker
    • 3.2
    • 3.2
    • Messages
    • MOODLE_32_STABLE
    • MOODLE_32_STABLE
    • MDL-56430-master
    • Hide

      Please test on both php5 and php7.

      1. Make sure that there are mail processors enabled other than the web one (see site admin > plugins > message outputs > manage message outputs)
      2. Log in as a user
      3. Navigate to the user's notification preferences (click the notification popover in the nav bar and click the cog icon)
      4. Change the settings of one of the notification processors (email for example) by clicking on the name of the processor (if it's configurable then the name should show as a link and have a cog next to it). Clicking the name should open a modal with the processor's settings.
      5. Save the changes in the modal
      6. Click the processor settings again and ensure that the modal is loaded with the correct settings (ones you changes).
      7. Refresh the page, click on the processor settings again and ensure they are still correct.
      Show
      Please test on both php5 and php7. Make sure that there are mail processors enabled other than the web one (see site admin > plugins > message outputs > manage message outputs) Log in as a user Navigate to the user's notification preferences (click the notification popover in the nav bar and click the cog icon) Change the settings of one of the notification processors (email for example) by clicking on the name of the processor (if it's configurable then the name should show as a link and have a cog next to it). Clicking the name should open a modal with the processor's settings. Save the changes in the modal Click the processor settings again and ensure that the modal is loaded with the correct settings (ones you changes). Refresh the page, click on the processor settings again and ensure they are still correct.

    Description

      As a user
      I want to set my jabberid
      Given I open the Notification preferences page
      And I open the configuration settings for jabber
      And I enter my ID and save
      When I reopen the settings
      Then I should see the value I just saved

      It's empty

      Note: Also happens for Mail preferences
      Nothing in apache error log

      Attachments

        Activity

          People

            ryanwyllie Ryan Wyllie
            dobedobedoh Andrew Lyons
            Andrew Lyons Andrew Lyons
            David Monllaó David Monllaó
            Adrian Greeve Adrian Greeve
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Clockify

                Error rendering 'clockify-timesheets-time-tracking-reports:timer-sidebar'. Please contact your Jira administrators.