Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-56438

Multimedia (embed or filter) not working on iOS 10

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 3.0.6, 3.1, 3.1.2
    • Fix Version/s: None
    • Component/s: Filters
    • Labels:
      None
    • Affected Branches:
      MOODLE_30_STABLE, MOODLE_31_STABLE

      Description

      Audio and video does not play on iOS 10.
      Either with the multimedia filters or when filters are turned off and we use standard HTML5 Audio.

      Works fine in Android, just not iOS.
      Tested on Moodle Cloud too - same issue.

      To replicate:

      1. Create a label
      2. Add a link to either an .mp3, .m4v, .ogg file
      3. Save the label
      4. Player works on desktop
      5. Player works on Android mobile devices, does not work on iOS10.
        All that is shown is a play button that is not clickable.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              lewiscarr Lewis Carr
              Participants:
              Component watchers:
              Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Sara Arjona (@sarjona)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: