Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-56595

User tours set_url doesn't appear to include the url params

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.2
    • Fix Version/s: None
    • Component/s: User Tours
    • Labels:
      None
    • Affected Branches:
      MOODLE_32_STABLE

      Description

      When testing user tours multilang I noticed this one. To replicate it:

      • First, install a few language packs (at least 2 required)
      • Create a new user tour
      • Create a step in the tour and save
      • Edit the step you just created (stay on the edit page)
      • Now, change language and notice that you're redirected back to the main user tours list page (configure.php?lang=xxx). It seems the url doesn't include the params required to stay on the current page, which IMO should be the desired behaviour when switching languages.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jaked Jake Dallimore
                Participants:
                Component watchers:
                Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated: