Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-56631

Password fields do not work on admin pages.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 3.2
    • Fix Version/s: 3.2
    • Component/s: General
    • Labels:
    • Testing Instructions:
      Hide

      In clean and boost:

      Go to "Site administration  ► Plugins  ► Message outputs  ► Email" and try to enter some text into "SMTP password". You should be able to set a password and save the form. You should verify the value was saved correctly.

      Show
      In clean and boost: Go to "Site administration  ► Plugins  ► Message outputs  ► Email" and try to enter some text into "SMTP password". You should be able to set a password and save the form. You should verify the value was saved correctly.
    • Affected Branches:
      MOODLE_32_STABLE
    • Fixed Branches:
      MOODLE_32_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-56631-master

      Description

      Replication steps:

      1. Go to "Site administration  ► Plugins  ► Message outputs  ► Email" and try to enter some text into "SMTP password".
      2. Alternatively go to "Site administration  ► Server  ► Incoming mail configuration  ► Mail settings" and try to change the password under "Incoming mail server settings"
      • Expected behaviour - The text changes into a text field to allow the insertion of a password.
      • Actual behaviour - Nothing happens.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  5/Dec/16