Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-56634

Web services API Documentation page only loads the first Web service

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide
      1. Go to webservice api documentation
      2. Make sure you see api description of all WS apis not just one.
      3. Add <noscript> tag to parameter description and description of response fields in a ws api.
      4. Reload the page, and make sure there are no issues.
      Show
      Go to webservice api documentation Make sure you see api description of all WS apis not just one. Add <noscript> tag to parameter description and description of response fields in a ws api. Reload the page, and make sure there are no issues.
    • Affected Branches:
      MOODLE_32_STABLE
    • Fixed Branches:
      MOODLE_30_STABLE, MOODLE_31_STABLE
    • Pull Master Branch:
      MDL-56634-master

      Description

      Using Moodle master up to date. I go to Site administration > Plugins > Web services > API Documentation. I expected to see the full list of Web services, but only the first one is shown.

      I tested it in 2 different sites in different servers.

        Attachments

          Activity

            People

            Assignee:
            ankit_frenz Ankit Agarwal
            Reporter:
            dpalou Dani Palou
            Peer reviewer:
            Adrian Greeve
            Integrator:
            Andrew Nicols
            Tester:
            Simey Lameze
            Participants:
            Component watchers:
            Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze, Juan Leyva, Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona), Víctor Déniz Falcón
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              14/Nov/16