Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-56918

theme_boost: single_select no longer supports HTML entities

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 3.2
    • Fix Version/s: None
    • Component/s: Forms Library, Themes
    • Labels:
      None
    • Affected Branches:
      MOODLE_32_STABLE

      Description

      As part of the conversion to templates, the single select no longer displays HTML entities. They are instead displayed as text (meaning if you want to display an & you can no longer send & or insert a non-breaking space   it will display the text '&nbsp' in place of the character.

      The attached file demonstrates the problem. Simply copy to the root of the moodle site and view the page in both clean and boost. It will display correctly in clean, but will display incorrectly in Boost. (There seems to be some conversion difference between how it is handled in Boost as opposed to clean)

      To see a real-world application of how this bug is affecting moodle you can see it here (contributed plugin)
      https://github.com/sbourget/moodle-mod_pcast/blob/master/locallib.php#L199

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              sbourget Stephen Bourget
              Participants:
              Component watchers:
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias, Bas Brands
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: