Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-57086

JS from filters is not executed when sending messages in AJAX or switching between conversations

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Critical
    • Resolution: Duplicate
    • 3.2
    • None
    • Media, Messages
    • None
    • MOODLE_32_STABLE

    Description

      1. Enable urltolink filter and mediaplugin filter (urltolink first), make sure video.js is enabled (should be by default)
      2. Open messaging interface and send somebody a link: http://www.sample-videos.com/video/mp4/720/big_buck_bunny_720p_1mb.mp4
      3. the video is not displayed in video.js
      4. reload page
      5. video is displayed in video.js

      When media_videojs is engaged it adds JS code to the page. This additional JS seems to be lost when posting messages in AJAX or switching between conversations.

      Attachments

        Issue Links

          Activity

            People

              markn Mark Nelson
              marina Marina Glancy
              David Woloszyn, Huong Nguyen, Jake Dallimore, Meirza, Michael Hawkins, Raquel Ortega, Safat Shahin, Stevani Andolo, David Woloszyn, Huong Nguyen, Jake Dallimore, Meirza, Michael Hawkins, Raquel Ortega, Safat Shahin, Stevani Andolo
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: