Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-57262

Re-implement curl TLS check by checking functionality rather than sniffing versions

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reopened
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.2
    • Fix Version/s: None
    • Component/s: Libraries
    • Labels:
    • Affected Branches:
      MOODLE_32_STABLE

      Description

      I'm testing 3.2. The environment check gets a warning that "No PHP/cURL extension with TLSv1.2 support has been detected. Some services may not work. It is strongly recommended to upgrade your TLS libraries."

      My hosting provider replies that there is the php-curl extension installed on the server but it should be directly deployed by the software with something like curl_setopt ($url, CURLOPT_SSLVERSION, 6)

      I can't say that I fully understand everything above but is it really possible to solve it within moodle code?

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              goryntsev Alexander Goryntsev
              Participants:
              Component watchers:
              Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona)
              Votes:
              2 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated: