Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-57366

Lesson doesn't save a numerical answer of zero on first attempt.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.3
    • Fix Version/s: 3.1.4, 3.2.1
    • Component/s: Lesson
    • Labels:
    • Testing Instructions:
      Hide
      1. Create a lesson activity.
      2. Add a numerical question.
      3. In the section "Answer 1" - Answer type in '0'
      4. Add some content to the response.
      5. Click "Save page"
      6. Edit the newly created numerical question.
      7. Check that "Answer 1" has an answer of '0' and that the response content is still present.
      Show
      Create a lesson activity. Add a numerical question. In the section "Answer 1" - Answer type in '0' Add some content to the response. Click "Save page" Edit the newly created numerical question. Check that "Answer 1" has an answer of '0' and that the response content is still present.
    • Difficulty:
      Easy
    • Affected Branches:
      MOODLE_33_STABLE
    • Fixed Branches:
      MOODLE_31_STABLE, MOODLE_32_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      wip-MDL-57366-master

      Description

      When creating a numerical question in the lesson and giving an answer of '0' the answer will be disregarded and not saved. Going back in and editing the question and giving an answer of '0' will however save.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  9/Jan/17