Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-57432

Decide Moodle 3.4 requirements and push them to environment.xml (due date: 29/05/2017)

    Details

    • Testing Instructions:
      Hide

      On Master, 33, 32 and 31:
      1) Go to admin -> server -> environment
      2) One "3.4 upwards" Moodle version should be available.
      3) It shows the same requirements than a 3.3 version but with these differences:

      • Moodle 3.0 is required
      • PHP Version requirement is 7.0.0
      • Intl extension is required

      On master only:
      1) Use php version 5.6 and verify that you get minimum version error reported when using:

        • The cli installers (both admin/cli/install.php and admin/cli/install_database.php)
        • The web installer (install.php)
        • Visiting /admin/ (on previously installed site)
          2) Ensure you have php 7.x, but disable the intl extension
          3) Verify you can get to the environment check page, but can't upgrade
          4) Enable the intl extension and verify you can upgrade

      Upgrade tests:

      1. Install Moodle 3.0.0, add some courses and and actviity or two
      2. Attempt upgrade to master
      3. VERIFY: that upgrade works
      1. Install Moodle 2.9.x
      2. Attempt to upgrade to master
      3. VERIFY: that upgrade is blocked
      Show
      On Master, 33, 32 and 31: 1) Go to admin -> server -> environment 2) One "3.4 upwards" Moodle version should be available. 3) It shows the same requirements than a 3.3 version but with these differences: Moodle 3.0 is required PHP Version requirement is 7.0.0 Intl extension is required On master only: 1) Use php version 5.6 and verify that you get minimum version error reported when using: The cli installers (both admin/cli/install.php and admin/cli/install_database.php) The web installer (install.php) Visiting /admin/ (on previously installed site) 2) Ensure you have php 7.x, but disable the intl extension 3) Verify you can get to the environment check page, but can't upgrade 4) Enable the intl extension and verify you can upgrade Upgrade tests: Install Moodle 3.0.0, add some courses and and actviity or two Attempt upgrade to master VERIFY: that upgrade works Install Moodle 2.9.x Attempt to upgrade to master VERIFY: that upgrade is blocked
    • Affected Branches:
      MOODLE_33_STABLE
    • Fixed Branches:
      MOODLE_31_STABLE, MOODLE_32_STABLE, MOODLE_33_STABLE
    • Pull 3.1 Branch:
    • Pull 3.2 Branch:
    • Pull 3.3 Branch:
    • Pull Master Branch:
      MDL-57432-master

      Description

      We need to decide ASAP about all the PHP/DB/Moodle versions requirements and put all them into the environmental tests (adding them to all supported branches).

      All the still open linked issues have been cloned here from the 3.3 sister issue (MDL-54901).

      Usual discussions:

      Feel free to propose areas to be discussed here. A numbered list with all them will be created to vote and decide the final outcomes of this issue.

      TIA and ciao

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  26 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    11/Sep/17