Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-57560

File upload progress bar not visible in boost

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide

      In Boost.

      Open developer tools, network tab and select the "Slow 3G preset". 

      Add or edit a file resource in a course.

      Drag and drop a file onto the file manager.

      Verify you see a progress bar that increases as the file is uploaded.

      Go back to the course page.

      Drag and drop a file directly onto the course page.

      Choose "Create file resource".

      Verify you see a progress bar that increases as the file is uploaded.

      Drag and drop a file directly onto the course page.

      Choose "Add media to course page".

      Verify you see a progress bar that increases as the file is uploaded.

      Show
      In Boost. Open developer tools, network tab and select the "Slow 3G preset".  Add or edit a file resource in a course. Drag and drop a file onto the file manager. Verify you see a progress bar that increases as the file is uploaded. Go back to the course page. Drag and drop a file directly onto the course page. Choose "Create file resource". Verify you see a progress bar that increases as the file is uploaded. Drag and drop a file directly onto the course page. Choose "Add media to course page". Verify you see a progress bar that increases as the file is uploaded.
    • Affected Branches:
      MOODLE_32_STABLE, MOODLE_33_STABLE, MOODLE_34_STABLE
    • Fixed Branches:
      MOODLE_32_STABLE, MOODLE_33_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-57560-master

      Description

      Reported by John U on https://moodle.org/mod/forum/discuss.php?d=345073#p1391781

      Steps to reproduce (you need a non-local machine to make it 'slow enough' to see, try qa.moodle.net)

      1. In theme_boost
      2. Go to a forum
      3. Create a new post
      4. Drag and drop a large-ish file into the file area

      Expected results:
      * A progress bar is displayed when the file is being uploaded

      Actual results:

      • No progress bar and the uploaded icon just appears.

      This doesn't appear to be a problem in clean

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              damyon Damyon Wiese
              Reporter:
              poltawski Dan Poltawski
              Peer reviewer:
              David Monllaó
              Integrator:
              Jun Pataleta
              Tester:
              Simey Lameze
              Participants:
              Component watchers:
              Bas Brands
              Votes:
              15 Vote for this issue
              Watchers:
              21 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                13/Nov/17