Moodle
  1. Moodle
  2. MDL-576

Review shows Error: Unknown question type! when quiz has been changed

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.1
    • Fix Version/s: None
    • Component/s: Quiz
    • Labels:
      None
    • Environment:
      All
    • Database:
      Any
    • Affected Branches:
      MOODLE_11_STABLE
    • Rank:
      13483

      Description

      Recreate the bug this way:

      • Let the student attempt a quiz!
      • When the attempt is saved, add one more question to the quiz!
      • Thereafter, review the attempt of the student. You will then get the notification Unknown question type! for the new question.

      It could be that you need to be in debug mode to get the error notification. I have not yet investigated how debug mode works.

        Activity

        Hide
        Martin Dougiamas added a comment -

        From Henrik Kaipe (kaipe at users.sourceforge.net) Monday, 4 August 2003, 04:43 AM:

        I believe I have stumbled on the root cause for this bug. I am working on a resolution.

        From Henrik Kaipe (kaipe at users.sourceforge.net) Monday, 4 August 2003, 05:54 AM:

        As with revision 1.93 of quiz/lib.php the problem is resolved. The message Recently added question! is shown together with the question text, unless it is a random question.

        However, right now you get the message [[recentlyaddedquestion]] as I don't have the karma to update lang/en. Whoever commits the final adjustment in lang/quiz/en/quiz.php will have the honor to close this bug.

        From Martin Dougiamas (martin at moodle.com) Monday, 4 August 2003, 09:36 AM:

        Good stuff!

        The honour is all yours! .. I added permissions so you can edit lang/en and lang/sv

        From Henrik Kaipe (kaipe at users.sourceforge.net) Tuesday, 5 August 2003, 07:42 PM:

        Done

        Show
        Martin Dougiamas added a comment - From Henrik Kaipe (kaipe at users.sourceforge.net) Monday, 4 August 2003, 04:43 AM: I believe I have stumbled on the root cause for this bug. I am working on a resolution. From Henrik Kaipe (kaipe at users.sourceforge.net) Monday, 4 August 2003, 05:54 AM: As with revision 1.93 of quiz/lib.php the problem is resolved. The message Recently added question! is shown together with the question text, unless it is a random question. However, right now you get the message [ [recentlyaddedquestion] ] as I don't have the karma to update lang/en. Whoever commits the final adjustment in lang/quiz/en/quiz.php will have the honor to close this bug. From Martin Dougiamas (martin at moodle.com) Monday, 4 August 2003, 09:36 AM: Good stuff! The honour is all yours! .. I added permissions so you can edit lang/en and lang/sv From Henrik Kaipe (kaipe at users.sourceforge.net) Tuesday, 5 August 2003, 07:42 PM: Done
        Hide
        Michael Blake added a comment -

        assign to a valid user

        Show
        Michael Blake added a comment - assign to a valid user

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: