Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-57851

Few scenarios fail on slow machine

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide
      1. git clone https://github.com/rajeshtaneja/docker
      2. sudo docker pull rajeshtaneja/php:7.0
      3. sudo docker pull rajeshtaneja/selenium:2.53.1
      4. sudo docker pull postgres
      5. cd docker
      6. run following command and ensure you don't see "Remove a section" failure ./run.sh --execute=behat --moodlepath="/path/to/yourmoodle" --phpversion=7.0 --profile=phantomjs-selenium --dbtype=pgsql --tags=@mod_quiz -j3

      NOTE:

      1. the 'moodlepath' can not contain ~/, so use /home/<user>/
      Show
      git clone https://github.com/rajeshtaneja/docker sudo docker pull rajeshtaneja/php:7.0 sudo docker pull rajeshtaneja/selenium:2.53.1 sudo docker pull postgres cd docker run following command and ensure you don't see "Remove a section" failure ./run.sh --execute=behat --moodlepath="/path/to/yourmoodle" --phpversion=7.0 --profile=phantomjs-selenium --dbtype=pgsql --tags=@mod_quiz -j3 NOTE: the 'moodlepath' can not contain ~/, so use /home/<user>/
    • Affected Branches:
      MOODLE_31_STABLE, MOODLE_32_STABLE, MOODLE_33_STABLE
    • Fixed Branches:
      MOODLE_31_STABLE, MOODLE_32_STABLE
    • Pull Master Branch:
      wip-mdl-57851

      Description

      Following failures has been observed on nightly because of slowness.

      https://integration.moodle.org/job/M.11%20Run%20all%20behat%20features%20in%20phantomjs-linux/764/console

      001 Scenario: Add questions from question bank to the quiz. In order to be able to
        add questions from question bank to the quiz, first we create some new questions
        in various categories and add them to the question bank. # /store/moodle/behat_whole_suite_m_phantom/mod/quiz/tests/behat/editing_add.feature:106
            And I set the field "item_qtype_essay" to "1"                                                                                                                                                                              # /store/moodle/behat_whole_suite_m_phantom/mod/quiz/tests/behat/editing_add.feature:145
              {"errorMessage":"Element is not currently visible and may not be manipulated","request":{"headers":{"Accept-Encoding":"gzip,deflate","Connection":"Keep-Alive","Content-Length":"27","Content-Type":"application/json; charset=utf-8","Host":"localhost:24418","User-Agent":"Apache-HttpClient/4.5.1 (Java/1.8.0_111)"},"httpVersion":"1.1","method":"POST","post":"{\"id\":\":wdc:1485955789629\"}","url":"/click","urlParsed":{"anchor":"","query":"","file":"click","directory":"/","path":"/click","relative":"/click","port":"","host":"","password":"","user":"","userInfo":"","authority":"","protocol":"","source":"/click","queryKey":{},"chunks":["click"]},"urlOriginal":"/session/7ec3e090-e876-11e6-8626-754624160858/element/:wdc:1485955789629/click"}}
              Build info: version: '2.53.1', revision: 'a36b8b1', time: '2016-06-30 17:37:03'
              System info: host: 'nightly', ip: '127.0.1.1', os.name: 'Linux', os.arch: 'amd64', os.version: '3.13.0-91-generic', java.version: '1.8.0_111'
              Driver info: driver.version: unknown (WebDriver\Exception\ElementNotVisible)
       
      002 Scenario: Remove a section      # /store/moodle/behat_whole_suite_m_phantom/mod/quiz/tests/behat/editing_section_headings.feature:127
            Then I should see "Heading 1" # /store/moodle/behat_whole_suite_m_phantom/mod/quiz/tests/behat/editing_section_headings.feature:153
              Javascript code and/or AJAX requests are not ready after 10 seconds. There is a Javascript error or the code is extremely slow. (Exception)
      

      https://integration.moodle.org/job/M.14%20Run%20all%20behat%20features%20in%20chrome-linux/615/console

      001 Scenario: Preview a question using the mouse.                              # /store/moodle/behat_whole_suite_m_chrome/question/type/ddimageortext/tests/behat/preview.feature:28
            Then the state of "Identify the features" question is shown as "Correct" # /store/moodle/behat_whole_suite_m_chrome/question/type/ddimageortext/tests/behat/preview.feature:45
              Question "Identify the features" state is not "Correct" (Behat\Mink\Exception\ExpectationException)
      

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                13/Mar/17