Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-57876

After 3.2.1+ update YUI-problem - buttons not working. Mathjax?

    Details

    • Affected Branches:
      MOODLE_32_STABLE

      Description

      After updating my site bearsea.info to 3.2.1+ early january 2017 (and latest update on Feb. 1) all kinds of navigation buttons
      stopped working - e.g. Expand/Collapse and the Submit all and finish button in Quiz (Note: The Return to attempt button above the Submit button works!). Disabling javascript makes the Submit button clickable.
      Atto and TinyMCE editors are not visible.
      The .../moodle/admin/phpinfo.php is empty.
      Cannot create questions because drop down menu Create a new question is not working.
      In general drop down menus don't work properly.

      Bug confirmed in Mac, Win, iOs - Safari, Chrome, Firefox.

      The Submit button

      Google Console:
      Uncaught TypeError: Cannot read property 'configure' of undefined
      at summary.php?attempt=5701:712
      at YUI._notify (yui_combo.php?rollup/3.17.2/yui-moodlesimple-min.js&rollup/1486285001/mcore-min.js:9)
      at yui_combo.php?rollup/3.17.2/yui-moodlesimple-min.js&rollup/1486285001/mcore-min.js:9
      at YUI._notify (yui_combo.php?rollup/3.17.2/yui-moodlesimple-min.js&rollup/1486285001/mcore-min.js:9)
      at YUI.T (yui_combo.php?rollup/3.17.2/yui-moodlesimple-min.js&rollup/1486285001/mcore-min.js:9)
      at e.Loader._finish (yui_combo.php?rollup/3.17.2/yui-moodlesimple-min.js&rollup/1486285001/mcore-min.js:16)
      at e.Loader._onSuccess (yui_combo.php?rollup/3.17.2/yui-moodlesimple-min.js&rollup/1486285001/mcore-min.js:16)
      at e.Loader.p (yui_combo.php?rollup/3.17.2/yui-moodlesimple-min.js&rollup/1486285001/mcore-min.js:17)
      at e.Loader.onSuccess (yui_combo.php?rollup/3.17.2/yui-moodlesimple-min.js&rollup/1486285001/mcore-min.js:17)
      at s._finish (yui_combo.php?rollup/3.17.2/yui-moodlesimple-min.js&rollup/1486285001/mcore-min.js:12)

      Gives an error here for Mathjax and YUI:
      Y.use("moodle-filter_mathjaxloader-loader",function() {M.filter_mathjaxloader.configure({"mathjaxconfig":"MathJax.Hub.Config({\r\nconfig: [\"Accessible.js\", \"Safe.js\"],\r\nerrorSettings:

      { message: [\"!\"] }

      ,\r\nskipStartupTypeset: true,\r\nmessageStyle: \"none\"\r\n});","lang":"en"});

      Still the Mathjax seems to be working somewhat on the site. I could add ML into a text but
      not TEX equation.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: