Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-57936

Coding error detected, it must be fixed by a programmer: The data source class does not exist.

    XMLWordPrintable

    Details

    • Affected Branches:
      MOODLE_30_STABLE

      Description

      Hi,
      I am trying to upgrade Moodle 2.6 to 2.7 and than to 3.2. Or 2.6 to 3.0.8 to 3.2. But for some reason I can't. This is the error:

      Coding error detected, it must be fixed by a programmer: The data source class does not exist.

      Debug info:
      Error code: codingerror
      Stack trace:
      line 498 of /cache/classes/definition.php: coding_exception thrown
      line 515 of /cache/classes/helper.php: call to cache_definition::load()
      line 480 of /cache/classes/helper.php: call to cache_helper::purge_store()
      line 323 of /admin/index.php: call to cache_helper::purge_all()

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                5 Vote for this issue
                Watchers:
                13 Start watching this issue

                Dates

                • Created:
                  Updated: