Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-58442

Improve core_container based on integration feedback

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.3
    • Fix Version/s: None
    • Component/s: Calendar

      Description

      1. The core_ prefix is confusing and doesn't really add any value. It would be better to rename it simple 'container'.
      2. The container should be well documented as it's the place where all the building blocks are composed together to achieve the functionality we need.
      3. Since the container acts as a quasi-DI container, as well as deciding on concrete implementations to use, factories that are used only in the container are redundant.
        • From the most recent IR: "Without dependency injection or similar systems, factories must serve a purpose to be useful; event_factory & event_abstract_factory together or separated make sense. I don't see though how action_event_factory serve any purpose, it is exactly the same to hardcode 'action_event_factory' in core_container than to hardcode 'new action_event', without a purpose nor an extension point they are 100% redundant. Getting rid of them would also kill action_event_factory_interface"

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              cameron1729 cameron1729
              Reporter:
              cameron1729 cameron1729
              Peer reviewer:
              Ryan Wyllie
              Participants:
              Component watchers:
              Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: