Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-58497

Forum always shows 1 for itemcount

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.3
    • Fix Version/s: 3.3
    • Component/s: Blocks, Forum
    • Labels:
    • Testing Instructions:
      Hide
      1. Go to an forum and set "Expected completion date in future"
      2. Set "min completion replies to 5"
      3. Set "Min completion discussions to 2"
      4. Visit course as a student who has no posts and make sure besides the action event in course overview block you see the number 7
      5. As the student, make a reply and a new discussion.
      6. Make sure the number now is 5
      7. Run unit tests.
      Show
      Go to an forum and set "Expected completion date in future" Set "min completion replies to 5" Set "Min completion discussions to 2" Visit course as a student who has no posts and make sure besides the action event in course overview block you see the number 7 As the student, make a reply and a new discussion. Make sure the number now is 5 Run unit tests.
    • Affected Branches:
      MOODLE_33_STABLE
    • Fixed Branches:
      MOODLE_33_STABLE
    • Pull Master Branch:
      MDL-58497-master

      Description

      The forum activity will always show 1 for the item count and it is always visible to the user. It seems like it should either be a count of the unread posts (if that matches the completion criteria set) or the item count shouldn't be visible to the user (we don't show the item count for any other activity when it is 1).

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                15/May/17