Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-58681

get_and_set_fields.feature started failing recently

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide

      Can be assigned to CiBoT and verify that "all feature" jobs (those running non-js scenarios) @ nightly stop reporting this problem:

      Alternatively, to run admin/tool/behat/tests/behat/get_and_set_fields.feature with both default (boost) and clean suites. It should simply pass without any failure.

      Show
      Can be assigned to CiBoT and verify that "all feature" jobs (those running non-js scenarios) @ nightly stop reporting this problem: M.08 M.21 ... Alternatively, to run admin/tool/behat/tests/behat/get_and_set_fields.feature with both default (boost) and clean suites. It should simply pass without any failure.
    • Affected Branches:
      MOODLE_33_STABLE
    • Fixed Branches:
      MOODLE_33_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      It seems that the non-javascript scenario "with JS disabled all form fields getters and setters works as expected" part of "admin/tool/behat/tests/behat/get_and_set_fields.feature" has started to fail recently.

      I've reproduced the same failure in 2 different servers (mac & linux) and also nightly is showing the same problem:

      Links: 1, 2.

      It started to fail somewhere between 6d14355ce8 and 04577e6599...

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  15/May/17