Moodle
  1. Moodle
  2. MDL-5893

Blackboard export/backup course does not restore to Moodle correctly

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.6.2
    • Fix Version/s: 1.6.3
    • Component/s: Questions
    • Labels:
      None
    • Environment:
      All
    • Database:
      Any
    • Affected Branches:
      MOODLE_16_STABLE
    • Fixed Branches:
      MOODLE_16_STABLE
    • Rank:
      28122

      Description

      We are currently using Blackboard 6.2.3 (build 6) and Moodle 1.5.2 here at SFSU and we are expecting that in Fall 2006 semester more and more instructors will switch to Moodle. However, we need to get prepared for doing a lot of BB to Moodle conversion and the current built-in (or inbuilt) BB to Moodle conversion tool provided by Moodle is not really good enough. We tested it for a lot of courses and most of the quizzes and discussion forums could not be migraded from BB to Moodle successfully (we tested it on 1.5.2, 1.5.3 and 1.6, all seems to have the same result). It seems that the Moodle community has stopped developing this conversion tool but we would like to continue to work on this. Hope to coordinate the efforts with the moodle dev team to come up with a plan to tackle this. Thanks!

      Currently we are taking a look at the codes that one of our previous student assistant Dina wrote (see: http://welearn.sfsu.edu/ctt/), and convert it into PHP codes to merge with the current Moodle built-in restore code. Dina's tool seem to do a much better job than the Moodle built-in tool, especially for the quiz part. I will upload some documents for you guys' reading pleasure...

        Activity

        Wen Hao Chuang created issue -
        Martin Dougiamas added a comment -

        From Eloy Lafuente (stronk7 at moodle.org) Sunday, 2 July 2006, 05:22 PM:

        Adding some more peoples here as I'm far away from the BB conversion stuff...

        From Wen Hao Chuang (wh_chuang at yahoo.com) Saturday, 29 July 2006, 06:36 AM:

        I noticed that in Moodle 1.6 there is now officially a quiz importing tool that support Blackboard 6.x., however this tool (in the questions module) is NOT working, please see this thread for more details. If possible please fix this problem ASAP as we will be converting a lot of Blackboard courses to Moodle in the near future, (same with other universities). thanks!

        http://moodle.org/mod/forum/discuss.php?d=49119

        From Howard Miller (howard.miller at udcf.gla.ac.uk) Tuesday, 8 August 2006, 10:32 PM:

        Yes I am aware that be BB6+ import is, shall we say, sub-optimal. Just to confuse things, it seemed to work fine for the limited test cases that I originally had for it but it is clearly unreliable in general. I have been doing some work on this, but not having access to a blackboard installation I am working blind.

        There has been quite of lot of people having problems with this, it does need some resource throwing at it but it really does need someone with more BB experience than me.

        Again, it would help immensely if you could post some of the files that you are having trouble with. Not too many questions though

        From Eloy Lafuente (stronk7 at moodle.org) Wednesday, 9 August 2006, 03:12 AM:

        Hi Howard, is it ok if I assign you this and others BB issues. I've been accumulating them in the bugs system without being really sure what to do with them.

        Cheers!

        From Eloy Lafuente (stronk7 at moodle.org) Wednesday, 9 August 2006, 03:13 AM:

        or, else, do you know the guy I should communicate all this stuff?

        Re-cheers :-P

        From Howard Miller (howard.miller at udcf.gla.ac.uk) Wednesday, 9 August 2006, 03:38 AM:

        Got it - any any others you have. It might be getting pulled out though, if nobody objects. The original developer is MIA, and I don't really have the resources to do a proper job with it.

        Can somebody get me access to a BB system, where I can create my own export files?

        From Wen Hao Chuang (wh_chuang at yahoo.com) Monday, 14 August 2006, 12:07 AM:

        Howard, I could create an BB 6.2 account for you. Please contact with me at enwen at sfsu dot edu (or) whchuang at gmail dot com

        Actually for the quiz importing tool, my team has fixed most of the problems (T/F, multiple questions, multiple answers, and fill-in-the-blanks, and essay question types are now working). We will post the codes to here later..

        From Howard Miller (howard.miller at udcf.gla.ac.uk) Monday, 14 August 2006, 02:26 AM:

        If you have got it all sorted - great! Please post the code asap, and we'll get it into 1.6.2.

        Have you tested with as many of the example BB files that you will find in the bug tracker and the forums as possible? This is were I came unstuck, some work perfectly and others completely break. Did the format change (again) after BB6 was released?

        Michael Blake made changes -
        Field Original Value New Value
        Assignee Howard Miller [ howardmiller ] Howard Miller [ howardsmiller ]
        Tom Trueluk added a comment -

        My company had asked me to work on this issue a few weeks ago, and I have created a tool that imports entire blackboard courses to moodle. This is blackboard 6(6.3 i think) and moodle 1.5.4+. I have imported well over 40 courses that all contain assignments, resources, forums, and quizzes. But, due to the code being specifically for our courses, I am sure that this importer will not convert all blackboard shells(well at least the assignments and some resources). But a plus is that it does infact import multiple choice, true/false, short response/fillintheblank, essay, matching, ordering, and multiple answer questions. Also adding the quizzes themselves with correct grades and random questions to the moodle course. The problem is, our content (resources on blackboard) are just links to the pages on our server and if this isn't how others use Blackboard then i would need to modify my code to accomodate them as well. Basically, I'm just asking if anyone here has any blackboard export shells that they could send me for my testing.

        I've used the zip file ExportFile_MOOD101pool.zip in the forum... http://moodle.org/mod/forum/discuss.php?d=49119 and all questions were fine. I haven't been able to find any other exports though, so if you know of where I can find some, links would be acceptable as well.

        And now im working on seperating the quiz part of my tool into it's own entity where it will convert blackboard quizzes/pools to moodle, which i should be able to release for your testing in the near future.

        Howard Miller added a comment -

        Main problems with BlackBoard version 6 have now been resolved.

        Howard Miller made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Fix Version/s 1.6.3 [ 10140 ]
        Resolution Fixed [ 1 ]
        Martin Dougiamas made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        QA Assignee nobody
        Martin Dougiamas made changes -
        Workflow jira [ 16574 ] MDL Workflow [ 52829 ]
        Martin Dougiamas made changes -
        Workflow MDL Workflow [ 52829 ] MDL Full Workflow [ 81915 ]

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: