Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-59078

Make predict_php 7.x requirement clearer

    XMLWordPrintable

Details

    • Task
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 3.4
    • None
    • Analytics
    • None

    Description

      The PHP predictions processor requires PHP 7.x to work because it is what php-ml library requires. We need to make this requirement clearer. We can not do it at plugin level because people can just use the python predictions processor or any other plugin they write, but we could show a warning message in the admin settings page if the server php version is lower than 7.0 and the PHP predictions processor is selected (it is the default value)

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              dmonllao David Monllaó
              Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Sara Arjona (@sarjona)
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: