Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-5912

Session timeout not taken into account when using dbsessions

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.6
    • Fix Version/s: 1.6.2, 1.7
    • Component/s: Libraries
    • Labels:
      None
    • Environment:
      All
    • Database:
      Any
    • Affected Branches:
      MOODLE_16_STABLE
    • Fixed Branches:
      MOODLE_16_STABLE, MOODLE_17_STABLE

      Description

      Moodle doesn't take into account the value specified in Admin >> Variables >> sessiontimeout when using dbsessions. The problem is in http://moodle.cvs.sourceforge.net/moodle/moodle/lib/setup.php

      This bug is in 1.5.x, 1.6.x and HEAD. See attached patch.

        Gliffy Diagrams

          Attachments

            Activity

            scotje Jesse Scott added a comment -

            This bug was driving me crazy until I figured out the cause.

            Here is a patch against 1.6.1. It's pretty straightforward and seems to work correctly.

            delius Gustav W Delius added a comment -

            Jesse, thank you very much for this patch. I have applied it to my site and will commit it to CVS in an hour or so.

            delius Gustav W Delius added a comment -

            I have comitted the fix to 1.5, 1.6 and HEAD


              People

              • Votes:
                1 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  12/Sep/06