Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-59159

Decide Moodle 3.5 requirements and push them to environment.xml (due date: 04/12/2017)

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide

      A - On Master, 34, 33, 32 and 31 (all supported and security supported branches):

      1. Go to admin -> server -> environment
      2. One "3.5 upwards" Moodle version should be available.
      3. It shows the same requirements than a 3.4 version but with these differences:
        • Moodle 3.1 is required

      B - Verify, for all the numeric (XY) branches above, that the environment.xml file is 100% the same (requires git or diff use). All the commands should return NO differences:

      1. git diff MOODLE_XY_STABLE master admin/environment.xml

      C - Upgrade tests:

      1. Install Moodle 3.1.0, add some courses and and actviity or two
      2. Attempt upgrade to master
      3. VERIFY: that upgrade works
      1. Install Moodle 3.0.x
      2. Attempt to upgrade to master
      3. VERIFY: that upgrade is blocked
      Show
      A - On Master, 34, 33, 32 and 31 (all supported and security supported branches): Go to admin -> server -> environment One "3.5 upwards" Moodle version should be available. It shows the same requirements than a 3.4 version but with these differences: Moodle 3.1 is required B - Verify, for all the numeric (XY) branches above, that the environment.xml file is 100% the same (requires git or diff use). All the commands should return NO differences: git diff MOODLE_XY_STABLE master admin/environment.xml C - Upgrade tests: Install Moodle 3.1.0, add some courses and and actviity or two Attempt upgrade to master VERIFY: that upgrade works Install Moodle 3.0.x Attempt to upgrade to master VERIFY: that upgrade is blocked
    • Affected Branches:
      MOODLE_34_STABLE
    • Fixed Branches:
      MOODLE_31_STABLE, MOODLE_32_STABLE, MOODLE_33_STABLE, MOODLE_34_STABLE
    • Pull from Repository:
    • Pull 3.1 Branch:
    • Pull 3.4 Branch:
    • Pull Master Branch:

      Description

      Policy: PHP & Moodle supported versions

      Since Moodle 3.5 (MDL-59159), these rules apply to decide Minimum PHP and Moodle versions supported:

      1. A LTS will always require the previous LTS (or later) for upgrading.
      2. The maximum PHP version supported for a branch will be the max one achieved along the life of the branch. Usually with .0 releases but may happen later (we added support for php70 with 3.0.1, for example).
      3. The minimum PHP version supported for a branch will be the lower of:
        • The minimum version supported in any way by php the day of the Moodle release (so we provide slow, progressive increments).
        • The maximum PHP version supported by the previous LTS branch (so we guarantee jumping between LTS is possible without upgrading PHP at the same time).

      We need to decide ASAP about all the PHP/DB/Moodle versions requirements and put all them into the environmental tests (adding them to all supported branches).

      All the still open linked issues have been cloned here from the 3.4 sister issue (MDL-57432).

      Usual discussions:

      Feel free to propose areas to be discussed here. A numbered list with all them will be created to vote and decide the final outcomes of this issue.

      TIA and ciao

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                21 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  15/Jan/18