Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-59263

Edit and preview icons not showing in admin/usersroles.php

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide
      1. Log in as admin
      2. Go to site admin ->Users -> Browse list of users
      3. Click on a user name to go to user profile page (user should have any enrolments or role assignments)
      4. Click on Preferences
      5. Click on This user's role assignments
      6. Make sure next to each role there are icons "edit" and "check permissions"
      Show
      Log in as admin Go to site admin ->Users -> Browse list of users Click on a user name to go to user profile page (user should have any enrolments or role assignments) Click on Preferences Click on This user's role assignments Make sure next to each role there are icons "edit" and "check permissions"
    • Affected Branches:
      MOODLE_33_STABLE
    • Fixed Branches:
      MOODLE_33_STABLE
    • Pull Master Branch:
      wip-MDL-59263-master

      Description

      Wrong order of parameters in calls to pix_icon function (lines 196 and 197) prevent icons from rendering.

      Steps:

      1. Log in as admin
      2. Go to site admin ->Users -> Browse list of users
      3. Click on a user name to go to user profile page
      4. Click on Preferences
      5. Click on This user's role assignments
      6. Icons are not rendering

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  10/Jul/17