Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-59582

Prepare Moodle for NodeJS 8.2.0

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.1.7, 3.2.4, 3.3.1, 3.4
    • Fix Version/s: 3.2.5, 3.3.2
    • Component/s: JavaScript
    • Labels:
    • Testing Instructions:
      Hide

      Run npm install with npm v5.3.0 and ensure there are no lockfile differences.

      Repeat with node 4 (e.g. npm v2.15.11) and verify the same.

      (Note, npm v5.0.1 will cause differences, we can't avoid this)

      Show
      Run npm install with npm v5.3.0 and ensure there are no lockfile differences. Repeat with node 4 (e.g. npm v2.15.11) and verify the same. (Note, npm v5.0.1 will cause differences, we can't avoid this)
    • Affected Branches:
      MOODLE_31_STABLE, MOODLE_32_STABLE, MOODLE_33_STABLE, MOODLE_34_STABLE
    • Fixed Branches:
      MOODLE_32_STABLE, MOODLE_33_STABLE

      Description

      NodeJS 8.2.0 changes the npm-shrinkwrap.json again, and is breaking some of our automated processes as a result.

      See MDLSITE-5184 for further info.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              poltawski Dan Poltawski
              Reporter:
              dobedobedoh Andrew Nicols
              Integrator:
              Andrew Nicols
              Tester:
              Andrew Nicols
              Participants:
              Component watchers:
              Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Fix Release Date:
                11/Sep/17