Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-60023

moodle s3 repo does not support AWS4-HMAC-SHA256

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.1.6, 3.3
    • Fix Version/s: None
    • Component/s: Repositories
    • Labels:
    • Affected Branches:
      MOODLE_31_STABLE, MOODLE_33_STABLE

      Description

      moodle s3 repo does not appear to support the newer Version 4 signatures

      Getting the following error when using an eu-central-1 endpoint

       

      Default exception handler: Error while communicating with the repository 'S3'. Debug: S3::listBuckets(): [InvalidRequest] The authorization mechanism you have provided is not supported. Please use AWS4-HMAC-SHA256.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            jbollom Josh Bollom
            Participants:
            Component watchers:
            Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
            Votes:
            2 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated: