Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-6011

Cloze type exported questions (Moodle XML format) import failure

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.6
    • Fix Version/s: None
    • Component/s: Questions
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_16_STABLE

      Description

      When I want to import cloze type questions from Moodle XML format, the import goes without any problem, but the imported question are loosing they name. There is an if statement in the file http://moodle.cvs.sourceforge.net/moodle/moodle/question/format/xml/format.php at line 148 in the import_multianswer() function. I don't know where the variable $thequestion comes from, but when the statement is commented out, the import goes well!

      (sorry for my english...)

        Gliffy Diagrams

          Activity

          Hide
          dougiamas Martin Dougiamas added a comment -

          From Howard Miller (howard.miller at udcf.gla.ac.uk) Tuesday, 4 July 2006, 05:57 PM:

          Could you provide an example file that fails please. Thanks.

          From (vince at uranos.kodolanyi.hu) Tuesday, 4 July 2006, 06:07 PM:

          Sample file uploaded. The first 2 questions' type are cloze. This two questions have blank name after the import.

          From (vince at uranos.kodolanyi.hu) Tuesday, 4 July 2006, 06:09 PM:

          We use Moodle 1.6 + (2006050506)

          From Howard Miller (howard.miller at udcf.gla.ac.uk) Wednesday, 5 July 2006, 08:41 PM:

          Fixed in CVS. Appeared to be a typo.

          Show
          dougiamas Martin Dougiamas added a comment - From Howard Miller (howard.miller at udcf.gla.ac.uk) Tuesday, 4 July 2006, 05:57 PM: Could you provide an example file that fails please. Thanks. From (vince at uranos.kodolanyi.hu) Tuesday, 4 July 2006, 06:07 PM: Sample file uploaded. The first 2 questions' type are cloze. This two questions have blank name after the import. From (vince at uranos.kodolanyi.hu) Tuesday, 4 July 2006, 06:09 PM: We use Moodle 1.6 + (2006050506) From Howard Miller (howard.miller at udcf.gla.ac.uk) Wednesday, 5 July 2006, 08:41 PM: Fixed in CVS. Appeared to be a typo.

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: