Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-60399

LTI Content Item: does not populate icon url when https

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 3.2.5, 3.3.2, 3.4
    • Fix Version/s: None
    • Labels:
    • Affected Branches:
      MOODLE_32_STABLE, MOODLE_33_STABLE, MOODLE_34_STABLE

      Description

      1. Deploy a new manually configured tool 
        1. URL https://lti.tools/test/tp.php 
        2. Content Item support is enabled by checking Content Item message (shown when clicking show more)
        3. Use secret for the secret
        4. Assign a unique key
      2. In a course, create an external link
        1. Select the LTI Test tool as the provider
        2. Click on Select Content
        3. Click content item
        4. Select Bespoke Item
          1. Type: LtiLinkItem
          2. Title: Testing MDL 60276
          3. Icon URL: https://moodle.com/wp-content/themes/moodlecom/img/moodle.png
          4. Return Selection
        5. Expected: iconUrl has https://moodle.com/wp-content/themes/moodlecom/img/moodle.png, secureIconUrl is empty

      This is only an issue when moodle site is http and the tool returns an icon url over https. In that case, without that fix, the tool link will not be decorated with the icon in the course content.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                claudevervoort Claude Vervoort
                Participants:
                Component watchers:
                Adrian Greeve, Mihail Geshoski, Peter Dias
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: