Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-60503

Pin node version on all branches (to v8.9[.x])

    XMLWordPrintable

Details

    • MOODLE_32_STABLE, MOODLE_33_STABLE, MOODLE_34_STABLE
    • MOODLE_32_STABLE, MOODLE_33_STABLE
    • MDL-60503-master
    • Hide

      Run grunt with any version of node other than 8.9

      Verify grunt refuses to run

       

      Verifying that grunt does run with the correct version of node can be done by checking the travis build.

      Show
      Run grunt with any version of node other than 8.9 Verify grunt refuses to run   Verifying that grunt does run with the correct version of node can be done by checking the travis build.

    Description

      We need the build artifacts to be generated the same for all Moodle developers so we need to specify the node version used to generate the npm-shrinkwrap file. 

      Node has an LTS scheduled for October 31 - as soon as it is released we should lock to that version on all branches. 

      Attachments

        Issue Links

          Activity

            People

              damyon Damyon Wiese
              damyon Damyon Wiese
              Andrew Lyons Andrew Lyons
              Eloy Lafuente (stronk7) Eloy Lafuente (stronk7)
              Eloy Lafuente (stronk7) Eloy Lafuente (stronk7)
              Andrew Lyons, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                13/Nov/17