Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-60569

Registration on moodle.net - different emails are not saved

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.4
    • Fix Version/s: 3.4
    • Component/s: Hub
    • Labels:
    • Testing Instructions:
      Hide
      1. Create moodle site available from internet (use ngrok) running 3.4dev
      2. Open registration form and specify "different emails" for security and comm lists, register
      3. Open registration form again - make sure all information is displayed in the form the way you entered it (especially different emails)
      4. Uncheck one of "use different email" and update registration
      5. Open registration form again - make sure all information is displayed in the form the way you entered it
      6. Unregister to remove invalid sites from moodle.net
      Show
      Create moodle site available from internet (use ngrok) running 3.4dev Open registration form and specify "different emails" for security and comm lists, register Open registration form again - make sure all information is displayed in the form the way you entered it (especially different emails) Uncheck one of "use different email" and update registration Open registration form again - make sure all information is displayed in the form the way you entered it Unregister to remove invalid sites from moodle.net
    • Affected Branches:
      MOODLE_34_STABLE
    • Fixed Branches:
      MOODLE_34_STABLE
    • Pull Master Branch:
      wip-MDL-60569-master

      Description

      moodle.net was just updated to accomodate for the new email addresses

      1. Create moodle site available from internet (use ngrok) running 3.4dev
      2. Open registration form and specify "different emails" for security and comm lists, register
      3. Open registration form again - the different emails are "lost". If you click update or run scheduled task updating registration the emails are reset to the general one

      I checked that emails are sent correctly to moodle.net during initial registration

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  13/Nov/17