Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-60595

In External tool manage tool, LTI titles and descriptions are not passing multilang filters

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Waiting for peer review
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.3.2, 3.4, 3.5, 3.7.5, 3.8.2
    • Fix Version/s: None
    • Labels:
    • Testing Instructions:
      Hide
      1. Make sure you have multilang filter on and concerning language packs installed
      2. Go to Adminstration → Plugins → External tool → Manage tool
      3. Click "Add tool", then the "configure a tool manually" link
      4. Tool name: <span lang="en" class="multilang">Title EN</span><span lang="ru" class="multilang">заглавие RU</span>
      5. Tool URL: https://www.edu-apps.org/tool_redirect?id=educreations
      6. Tool description: <span lang="en" class="multilang">Description EN</span><span lang="ru" class="multilang">описание RU</span>
      7. Save changes
      8. On the Adminstration Plugins External tool Manage tool page (mod/lti/toolconfigure.php) verify the filters in the tool-cards displaying the preconfigured LTI tools do apply.
      9. Go to a course with editing permissions and add a new LTI activity.
      10. Verify the pulldown menu for "Preconfigured tools" applies the language filter.

      Show
      Make sure you have multilang filter on and concerning language packs installed Go to Adminstration → Plugins → External tool → Manage tool Click "Add tool", then the "configure a tool manually" link Tool name: <span lang="en" class="multilang">Title EN</span><span lang="ru" class="multilang">заглавие RU</span> Tool URL: https://www.edu-apps.org/tool_redirect?id=educreations Tool description: <span lang="en" class="multilang">Description EN</span><span lang="ru" class="multilang">описание RU</span> Save changes On the Adminstration Plugins External tool Manage tool page (mod/lti/toolconfigure.php) verify the filters in the tool-cards displaying the preconfigured LTI tools do apply. Go to a course with editing permissions and add a new LTI activity. Verify the pulldown menu for "Preconfigured tools" applies the language filter.
    • Affected Branches:
      MOODLE_33_STABLE, MOODLE_34_STABLE, MOODLE_35_STABLE, MOODLE_37_STABLE, MOODLE_38_STABLE
    • Pull 3.8 Branch:
    • Pull 3.9 Branch:
    • Pull Master Branch:
      MDL-60595-master

      Description

      • Make sure you have multilang filter on and concerning language packs installed
      • Go to Adminstration → Plugins → External tool → Manage tool
      • Click "Add tool", then the "configure a tool manually" link
      • Tool name: <span lang="en" class="multilang">Title EN</span><span lang="ru" class="multilang">заглавие RU</span>
      • Tool URL: https://www.edu-apps.org/tool_redirect?id=educreations
      • Tool description: <span lang="en" class="multilang">Description EN</span><span lang="ru" class="multilang">описание RU</span>
      • Save changes
      • On the Adminstration Plugins External tool Manage tool page (mod/lti/toolconfigure.php) the filters in the tool-cards displaying the preconfigured LTI tools do not apply.
      • When you are adding a new External tool filters in the Preconfigured tools pulldown menu do not apply.

        Attachments

          Activity

            People

            Assignee:
            lucaboesch Luca Bösch
            Reporter:
            lucaboesch Luca Bösch
            Participants:
            Component watchers:
            Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated: