Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-60665

Error in "users message" when debug mail is enable

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Won't Fix
    • 3.3.2
    • None
    • Messages
    • MOODLE_33_STABLE

    Description

      When send a direct message to other user (for example: message/index.php?user=2&id=3) with mail debug enable, Moodle return the following error:

      SyntaxError: Unexpected token < in JSON at position 0
      at parse (<anonymous>)
      at Nb (http://XXXXXXX/moodle/lib/javascript.php/1509435798/lib/jquery/jquery-3.1.0.min.js:1:74037)
      at A (http://XXXXXXX/moodle/lib/javascript.php/1509435798/lib/jquery/jquery-3.1.0.min.js:1:77562)
      at XMLHttpRequest.<anonymous> (http://XXXXXXX/moodle/lib/javascript.php/1509435798/lib/jquery/jquery-3.1.0.min.js:1:80166)

      In addition, message page not refresh correctly and remain wiht message "disable":  Unable to render embedded object: .

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              panidvd David Paniagua Ruano
              Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Laurent David, Raquel Ortega, Sara Arjona (@sarjona)
              Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: