Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-60803

Upgrade IMS-CC to support v1.2 and v1.3

    XMLWordPrintable

    Details

      Description

      THIS IS AN MUA PROJECT PROPOSAL THAT WILL BE OR HAS BEEN SUBMITTED FOR POSSIBLE MUA FUNDING.  ANY EXISTING TRACKER ITEMS THAT THIS MIGHT DUPLICATE SHOULD BE LINKED TO BELOW.  

      Overview

      Moodle currently supports IMS Common Cartridges conforming to the 1.0 and 1.1 version of the specification (Released May 2011).  These have been superseded by version 1.2 (October 2011) and 1.3 (July 2013).  
      Many textbook publishers (Such as pearson, TCI, etc) who do not currently support LTI support IMS-CC, but only the newer versions.
      It would be helpful if Moodle supported these versions as well.

      Al list of publishers providing IMS common cartridges can be found here: https://www.imsglobal.org/cc/statuschart/common-cartridge

      Summary

      Project size: medium
      Audience: primary schools, universities, work places
      Target users: teachers, students, administrators

      Goals

      Allow Moodle to import courses formatted in IMS Common Cartridge v1.2 or v1.3
      Allow Moodle to import courses formatted in IMS Thin Common Cartridge v1.3
      Allow Moodle to export courses formatted in IMS common cartridge v1.3

      User Stories

      As a teacher, I should be able to import IMS Thin CC formatted courses released by textbook publishers into my moodle course.
      As a teacher, I should be able to import IMS Common Cartridge v1.3 formatted courses released by textbook publishers into my moodle course.
      As an admin, I should be able to export courses in IMS common Cartrige v1.3 format

      Links to existing tracker issues, forum discussions, contrib plugins

      Moodle.org discussion on Thin Common cartridge, and Pearson Realize import - https://moodle.org/mod/forum/discuss.php?d=367402

      Requirements

      Moodle should be able to import IMSCC formatted course cartridges
      Moodle should be IMS certified for Common Cartridge 1.3 import and export
      Moodle should be IMS certified for Thin Common Cartridge 1.3 import

      Further reading

      https://www.imsglobal.org/cc/index.html
      https://www.teachtci.com/system-requirements/
      https://pearsonnacommunity.force.com/support/s/article/Realize-Thin-Common-Cartridge

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                2 Vote for this issue
                Watchers:
                12 Start watching this issue

                Dates

                • Created:
                  Updated: