Moodle
  1. Moodle
  2. MDL-6081

Questions are not laid out logically or consistenly

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.7
    • Fix Version/s: 2.1
    • Component/s: Questions
    • Labels:
      None
    • Affected Branches:
      MOODLE_17_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE
    • Rank:
      3229

      Description

      The way questions (with any answers, feedback, scores, etc) are laid out is not great. I think the features of the various question types have evolved over the years a bit at a time, and different questions have done different things.

      At some point, I'm going to have to sit down and look at this across all question types, and get a good clear and consistent layout for all this.

      A lot of the quiz user interface is like that. It has evolved into a bit of a mess a little at a time. The trouble is, it is adequate for getting most things done, even though it is not great, which makes fixing it a lower priority.

        Issue Links

          Activity

          Martin Dougiamas added a comment -

          From Tim Hunt (T.J.Hunt at open.ac.uk) Tuesday, 18 July 2006, 12:54 AM:

          I'm completely failing to reproduce this. Which sequence of buttons/links did you have to click to get that screenshot? Thanks.

          From non non (nbhansen at midway.uchicago.edu) Tuesday, 18 July 2006, 08:18 PM:

          Tim, I think this is occuring because of a series of hacks I made to my own site because I didn't like the way the correctness feature worked at all and wanted to remove it from display. It became an all or nothing issue though I think and then I added something else to bring the grade back without the correctness aspect. However, for some reason when I also commented on the grade, the grade was displayed twice.

          I am going to change this to a feature request to make dispalying correctness an optional feature. I just seems there is extreme redundancy going on. If a student gets a short answer correct, they are shown, for example:

          1-The correct answer (which is the same as their answer, so it offers little benefit)

          2-The word correct

          3-And a score reflecting it is correct, e.g. 1/1

          I'd rather see 1 displayed only when their answer isn't correct, and 2 and 3 all the time, or even just 3.

          I'm going back to the drawing board to see if I can't code this myself and I'll post it if I do.

          From non non (nbhansen at midway.uchicago.edu) Wednesday, 19 July 2006, 01:46 AM:

          There is a fourth redundancy to this and that is the fact that the total possible number of marks is listed on the left side of the page under the question number. This is appropriate when the quiz is yet to be submitted, but afterwards when it is already graded it is redundant since the grade itself includes the total marks.

          From non non (nbhansen at midway.uchicago.edu) Wednesday, 19 July 2006, 03:25 AM:

          OK, Tim, while I've made a hack for my own site I'm not posting it because it really isn't comprehensive. Instead, I'd just like to make some suggestions based on my experience tearing my hair out over this.

          What I think what is necessary is to overhaul type/questiontype.php and the various display.html files of the various question types, since now the information displayed for each question is drawn from these two files rather than from one place. It would be easier to customize the order of the various things displayed if there was a way to be able to change the order of these things by editing only one or the other file (in the case of display.html it might require changes to multiple files). A more logical display seems to me to be:

          1-Answer

          2-Correctness (because the first thing the student should be told is whether their answer is correct or not)

          3-Correct answer (only if correctness is less than correct)

          4-Feedback (this most likely is used to explain why or why not the student's answer is correct-although I don't actually use it that way but I am assuming here that is how teachers use it)

          5-Comment (if the teacher provides one, this might substitute for feedback in some cases)

          6-marks the student received (or this could be put between 2 and 3)

          Finally, if one is in review mode, then there would be no need to display the marks on the left side-those should only be displayed while the student is actually taking the quiz so they know the value of each question.

          From Tim Hunt (T.J.Hunt at open.ac.uk) Wednesday, 19 July 2006, 07:57 PM:

          I agree with you that the way questions are layed out, and the information is presented, is not great. I think the features in question types have evolved over the years, and different questions have done different things.

          So at some point, I'm going to have to sit down

          From Tim Hunt (T.J.Hunt at open.ac.uk) Wednesday, 19 July 2006, 08:03 PM:

          [[Curse it, I did not mean to hit save changes then. Ignore th e previous comment.]]

          I agree with you that the way questions (with any answers, feedback, scores, etc) are layed out is not great. I think the features of the various question types have evolved over the years a bit at a time, and different questions have done different things. This is not a recipe for good user interface.

          So at some point, I'm going to have to sit down and look at this across all question types, and get a good clear and consistent layout for all this.

          A lot of the quiz user interface is like that. It has evolved into a bit of a mess a little at a time. The trouble is, it is adequate for getting most things done, even though it is not great, which makes fixing it a lower priority.

          By the way, becuase the way to fix this is to sit down and think about the whole thing at once to achive consistency, I don't think it is very helpful to file lots of different bugs about individual usability issues, unless they realy are isolated things that it would be quick and easy to fix in isolation.

          N Hansen added a comment -

          Did someone change the subject of this from what it originally was? Because I can't imagine I would ever spell "laid" as "layed"

          Tim Hunt added a comment -

          Yes, sorry, I can't spell. I changed the summary so I knew what the actual issue was.

          Tim Hunt added a comment -

          The new question engine should resolve this.

          Tim Hunt added a comment -

          Fixed in 2.1 dev now that MDL-20636 has been integrated.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: