Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-60871

Search list incorrectly shows no results after selecting a user

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.4
    • Fix Version/s: None
    • Component/s: Enrolments
    • Labels:
    • Affected Branches:
      MOODLE_34_STABLE

      Description

      In the new enrol users control, if I search and see a list of users, then select one of them, I would expect the search results to continue to show the other users (or at worst some message saying I had to search again). What actually happens is that the search results disappear and a message saying "No suggestions" is shown.

      This appears to happen only when the search matches on email - when matching on name it works as expected.

      So, to reproduce:

      1. Create ten users: Person One (user1@example.com) etc
      2. Go into participants in a course and click "enrol users"
      3. Search for example.com
      4. Select one of the users
      5. The search results are replaced with a "no suggestions" label

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              maherne Michael Aherne
              Participants:
              Component watchers:
              Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Sara Arjona (@sarjona), Víctor Déniz Falcón
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated: