Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-61010

Blog-like forum doesn't scroll to new posts

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.4
    • Fix Version/s: 3.3.5, 3.4.2
    • Component/s: Forum
    • Labels:
    • Testing Instructions:
      Hide
      1. Go to a course
      2. Create a new forum in blog format
      3. Enrol another user in the course
      4. Log in as that user and, from the user menu, choose Preferences, then Forum preferences
      5. Select Yes: highlight news posts for me from the Forum tracking select and save changes.
      6. Log in as a different user
      7. Post a new topic in the forum, and then reply to it once.
      8. Post a second new topic in the same forum, and reply to it twice
      9. Log back in as the user with Forum tracking enabled, and open the the forum that you posted in
      10. Refresh the page
        1. Confirm that both posts are marked as having the correct number of unread replies
        2. Confirm that the count is a link
        3. Confirm that clicking on each link takes you to the first unread post in each discussion
      Show
      Go to a course Create a new forum in blog format Enrol another user in the course Log in as that user and, from the user menu, choose Preferences , then Forum preferences Select Yes: highlight news posts for me from the Forum tracking select and save changes. Log in as a different user Post a new topic in the forum, and then reply to it once. Post a second new topic in the same forum, and reply to it twice Log back in as the user with Forum tracking enabled, and open the the forum that you posted in Refresh the page Confirm that both posts are marked as having the correct number of unread replies Confirm that the count is a link Confirm that clicking on each link takes you to the first unread post in each discussion
    • Affected Branches:
      MOODLE_34_STABLE
    • Fixed Branches:
      MOODLE_33_STABLE, MOODLE_34_STABLE
    • Pull Master Branch:
      MDL-61010-master

      Description

      Hi,
      "Standard forum for general use" when there are new posts scrolls down to first new post.
      But blog-like forum doesn't
      There is a missing link "Unread".
      See suggested fix below.

       

      # diff lib_orig.php lib.php 
      3520c3520
      < $replystring .= get_string('unreadpostsone', 'forum');
      ---
      > $replystring .= html_writer::link($discussionlink.'#unread', get_string('unreadpostsone', 'forum'));
      3522c3522
      < $replystring .= get_string('unreadpostsnumber', 'forum', $discussion->unread);
      ---
      > $replystring .= html_writer::link($discussionlink.'#unread', get_string('unreadpostsnumber', 'forum', $discussion->unread));

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  19/Mar/18