Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-61056

Feedback response navigation elements not displayed correctly in Boost

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.4
    • Fix Version/s: 3.4.1
    • Component/s: Feedback
    • Labels:

      Description

      As noticed by Mark Nelson, the Feedback module page "Show responses" has broken links for navigating through responses. This seems to be a indirect regression of MDL-59313 that started to display links to navigate through activities.

      Steps to reproduce:

      1. Have a 3.4 site with the Boost theme
      2. Have at least 3 activity modules in a course with a Feedback module in the middle (with at least one module before, one after it).
      3. Define a simple question in the Feedback
      4. Submit answers to the Feedback as at least 3 students (so there are at least 3 responses)
      5. As a teacher, go to the "Show responses" tab
      6. Click on one of the responses

      Expected behaviour:

      • Links to navigate through the responses are nicely displayed

      Actual behaviour:

      • Links to navigate through the responses are broken, the "Back" link is completely covered with the "Jump..." selector.

        Attachments

        1. MDL-61056.xlsx
          16.81 MB
        2. screenshot-1-before.png
          screenshot-1-before.png
          24 kB
        3. screenshot-2-after.png
          screenshot-2-after.png
          24 kB

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                15/Jan/18