Moodle
  1. Moodle
  2. MDL-6122

Unicode: uses of substr, strlen, strpos, strtoupper... to use the new textlib class

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.6
    • Fix Version/s: 1.9.10
    • Component/s: General
    • Labels:
      None
    • Environment:
      All
    • Affected Branches:
      MOODLE_16_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE
    • Rank:
      28469

      Activity

      Hide
      Jay Knight added a comment -

      Is this known to still be an open issue? Because I seem to be experiencing problems with this. See my comments at MDL-3741 and http://moodle.org/mod/forum/discuss.php?d=159571. Is it a bug or do I have something configured incorrectly?

      Show
      Jay Knight added a comment - Is this known to still be an open issue? Because I seem to be experiencing problems with this. See my comments at MDL-3741 and http://moodle.org/mod/forum/discuss.php?d=159571 . Is it a bug or do I have something configured incorrectly?
      Hide
      Petr Škoda added a comment -

      Hopefully all solved by now, thanks!

      Show
      Petr Škoda added a comment - Hopefully all solved by now, thanks!
      Hide
      Jay Knight added a comment -

      But... my problems?!? Is `truncate_userinfo()` supposed to call plain-old `substr()` (lib/moodlelip.php, 3502) or should it be using 'mb_substr()` or textlib or something?

      Show
      Jay Knight added a comment - But... my problems?!? Is `truncate_userinfo()` supposed to call plain-old `substr()` (lib/moodlelip.php, 3502) or should it be using 'mb_substr()` or textlib or something?
      Hide
      Petr Škoda added a comment -

      oh! reopening, thanks!

      Show
      Petr Škoda added a comment - oh! reopening, thanks!
      Hide
      Petr Škoda added a comment -

      The truncate_userinfo() is fixed now. Please reopen if you find more places like this.

      Thanks!

      Show
      Petr Škoda added a comment - The truncate_userinfo() is fixed now. Please reopen if you find more places like this. Thanks!

        People

        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved: