Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-61827

Facebook OAuth2: Update Facebook Graph API to v2.12 in default configuration

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide

      To verify under the 3 branches:

      1. Configure Facebook OAuth2 login.
      2. Log in to any Facebook account.
      3. Use the button on the Moodle login page to login using Facebook.
      4. Make sure that Facebook OAuth2 login works correctly e.g.:
        • the user is correctly logged in/registered on Moodle using Facebook login,
        • information about the user are correctly imported from Facebook user profile.
      Show
      To verify under the 3 branches: Configure Facebook OAuth2 login . Log in to any Facebook account. Use the button on the Moodle login page to login using Facebook. Make sure that Facebook OAuth2 login works correctly e.g.: the user is correctly logged in/registered on Moodle using Facebook login, information about the user are correctly imported from Facebook user profile.
    • Affected Branches:
      MOODLE_33_STABLE, MOODLE_34_STABLE, MOODLE_35_STABLE
    • Fixed Branches:
      MOODLE_33_STABLE, MOODLE_34_STABLE
    • Pull Master Branch:

      Description

      Currently, the Graph API version 2.8 is used in the default Facebook OAuth2 settings. This Facebook Graph API version will be supported to next year, but we can now think about changing to a newer version (v2.12). I changed the default configuration.

      More about each version availibility on Facebook docs pages.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                17/May/18