Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-62013

Labels are not visible after hideIf conditions are not satisfied in theme_clean

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.4
    • Fix Version/s: None
    • Component/s: Forms Library
    • Labels:
      None
    • Affected Branches:
      MOODLE_34_STABLE

      Description

      1. If field1 hideIf condition is initially satisfied -> field1 and its label are hidden
      2. field1 hideIf condition is not satisfied anymore
      3. field1 and its label should be visible

      This is how things should work and how they work in theme_boost. However when trying the same with theme_clean and autocomplete / course fields the label is not visible.

      We detected this issue during MDL-60953 testing, we worked around the problem but this should ideally be fixed.

      PD: Note that bootstrap 2 themes will be moved out of core in 3.6

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                dmonllao David Monllaó
                Participants:
                Component watchers:
                Jake Dallimore, Jun Pataleta, Ryan Wyllie
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: