Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-6248

RSS Blocks missing after 1.6.1 upgrade

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.6.1
    • Fix Version/s: None
    • Component/s: RSS
    • Labels:
      None
    • Environment:
      All
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_16_STABLE

      Description

      After upgrading to the latest cvs earlier tonight, I found that for ordinary users, any RSS feed block was now invisible and that for admins they could see the block but only had Add/Edit feeds avalable.

      Editing the feed showed that it was setup correctly.

      This can be resolved by downgrading magpie to an earlier version - I only had 1.5.4 availble, but it works

        Gliffy Diagrams

          Activity

          dougiamas Martin Dougiamas added a comment -

          From Martin Dougiamas (martin at moodle.com) Monday, 14 August 2006, 11:32 PM:

          hmmm nothing new here http://moodle.cvs.sourceforge.net/moodle/moodle/lib/magpie/

          ...it's out to Skodak on the wing for a quick look!

          From Petr Skoda (skodak at centrum.cz) Tuesday, 15 August 2006, 01:22 AM:

          No downgrade, sorry - we will have to find the actual problem and fix it. Working on it...

          From Petr Skoda (skodak at centrum.cz) Tuesday, 15 August 2006, 02:28 AM:

          I have tested it on several linux based servers and it works for me with different RSS 1.0, 2.0 and Atom feeds. Using both various PHP 5.1.x and 4.4.x versions on different distributions.

          What is you server configuration? Could you send me output of admin/phpinfo.php by email? thanks

          From Petr Skoda (skodak at centrum.cz) Tuesday, 15 August 2006, 07:06 PM:

          I think the problem might be in snoopy not magpie itself. Before 1.6 magpie used medieval snoopy version from its exlib directory. It now uses latest version from lib/snoopy/ directory.

          I can not fix it if I can not reproduce it on my test servers

          Could you enable debug mode on your server and send me login/password or at least any error messages from web pages and server logs?

          From (sbryan at olmc.nsw.edu.au) Wednesday, 16 August 2006, 06:53 AM:

          UNfortunatley there are no error messages generated in any of the logs on the server itself, I looked in the web server logs and all the system logs.

          My site is currently working with the older version of Magpie and I can't really afford to 'break' it on purpose for any length of time during the school week.

          Can we organise a time on the next weekend, so that I can advise users that those features will not be working for a while?

          poltawski Dan Poltawski added a comment -

          Closing this old bug. Hopefully the problem causing this has been fixed over time since


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: