Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-62625

Bump moodlehq/behat-extension php requirements to php70

    XMLWordPrintable

    Details

    • Affected Branches:
      MOODLE_33_STABLE, MOODLE_34_STABLE, MOODLE_35_STABLE, MOODLE_36_STABLE

      Description

      Since Moodle 3.4, we require php 7.0.0 (link).

      In the other side, moodlehq/behat-extension declares php as (old) requirement (link).

      This issue is about to:

      • raise the requirement to php 7.0.0, for 34_STABLE and up.
      • paralel, decide if, for 33_STABLE, the same should be applied for php 5.6.5.
      • regenerate composer.lock, it should enable a number of updates.
      • verify phpunit and behat continue working without problems.

      (This issue was detected when working on MDL-62620 )

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              stronk7 Eloy Lafuente (stronk7)
              Reporter:
              stronk7 Eloy Lafuente (stronk7)
              Participants:
              Component watchers:
              Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: