Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-62791

LTI Enrolment doesn't unenrol students

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.3.6, 3.5
    • Fix Version/s: None
    • Component/s: LTI provider
    • Labels:
    • Affected Branches:
      MOODLE_33_STABLE, MOODLE_35_STABLE

      Description

      Hello,

      it seems LTI user syncronization doesn't unenrol users from the LTI provider course:

      1. Share course with LTI-registration method from the LTI Provider Moodle with settings:
        User synchronisation: Yes
        User synchronisation mode: enrol new and unenrol missing users.
      2. Enter LTI Provider Moodle course as a student from the LTI Customer site.
      3. Notice how student gets an student-role in LTI Provider site.
      4. Remove student from the LTI customer Moodle course.
      5. Notice that he/she isn't unenrolled from the LTI Provider Moodle even if you run "Publish as LTI tool users sync \enrol_lti\task\sync_members" by manually.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            urpokarhu Jari Vilkman
            Participants:
            Component watchers:
            Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias, Sujith Haridasan
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: