Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-63129

Install/upgrade should detect broken dependencies between plugins

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.4.4, 3.5.1
    • Fix Version/s: None
    • Component/s: Installation
    • Labels:
      None
    • Affected Branches:
      MOODLE_34_STABLE, MOODLE_35_STABLE

      Description

      Steps to reproduce:

      1. Install https://moodle.org/plugins/qtype_varnumericset
      2. Install https://moodle.org/plugins/qtype_varnumeric
      3. In question/type/varnumeric/version.php, edit the dependency on qtype_varnumericset to require version 2019081300 (which clearly does not exist).
      4. Run php admin/tool/phpunit/cli/init.php to do a Moodle install.

      Expected result: install should stop (or not even start) with an error about the unmet dependency. A similar think should happen on the plugin-check page during upgrade.

      Acutal results: Install/upgrade just works. (The problem is only apparent to users installing plugins from the Moodle plugings DB.)

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              timhunt Tim Hunt
              Participants:
              Component watchers:
              Matteo Scaramuccia, Andrew Nicols, Mathew May, Michael Hawkins, Shamim Rezaie, Simey Lameze
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: