Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-63232

Don't require global install of grunt for build process

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Not a bug
    • Affects Version/s: 3.5.1
    • Fix Version/s: None
    • Component/s: JavaScript
    • Labels:
      None
    • Affected Branches:
      MOODLE_35_STABLE

      Description

      Currently, `grunt` appears to be required globally to run the build process. The `.travis.yml` file includes installing grunt globally. However, `npm` can be leveraged to run `grunt` from `node_modules` where it is already being installed due to an entry in `package.json`.

      This change would mean that we'd only be installing `grunt` once rather than twice.

      It will also make the build process less brittle as installing globally requires super-user privileges in many environments.

      (If this is deemed an appropriate task to undertake, I'd be happy to do it.)

        Attachments

          Activity

            People

            • Assignee:
              dobedobedoh Andrew Nicols
              Reporter:
              trott Rich Trott
              Participants:
              Component watchers:
              Jake Dallimore, Jun Pataleta, Ryan Wyllie
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: