Moodle
  1. Moodle
  2. MDL-6325

In Lesson "import questions", check which formats accept import

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.6
    • Fix Version/s: 1.6.2, 1.7
    • Component/s: Lesson
    • Labels:
      None
    • Affected Branches:
      MOODLE_16_STABLE
    • Fixed Branches:
      MOODLE_16_STABLE, MOODLE_17_STABLE
    • Rank:
      28404

      Description

      Starting with 1.6 I think, question import/export formats begin with a declaration as to whether they provide import or export or both:
      function provide_import()

      { return true; }
      function provide_export() { return true; }

      The QUESTION import and export files do check those, through calling get_import_export_formats( 'import' ) or get_import_export_formats( 'export' ).
      The LESSON import file does not to this checking. It should.

      Joseph

        Activity

        Hide
        Mark Nielsen added a comment -

        Hi Joseph,

        I attached a diff made off of CVS MOODLE_16_STABLE. It appears to work fine. I tested it with the GIFT format. Could you give it a whirl to see if it works for you?

        Cheers,
        Mark

        Show
        Mark Nielsen added a comment - Hi Joseph, I attached a diff made off of CVS MOODLE_16_STABLE. It appears to work fine. I tested it with the GIFT format. Could you give it a whirl to see if it works for you? Cheers, Mark
        Hide
        Joseph Rézeau added a comment -

        Hi Mark,
        Yes, your attached diff works OK (tested with XML format).
        I guess you can commit it to CVS.
        Thanks

        Show
        Joseph Rézeau added a comment - Hi Mark, Yes, your attached diff works OK (tested with XML format). I guess you can commit it to CVS. Thanks
        Hide
        Mark Nielsen added a comment -

        In MOODLE_16_STABLE and merged into HEAD

        Show
        Mark Nielsen added a comment - In MOODLE_16_STABLE and merged into HEAD
        Hide
        Martin Dougiamas added a comment -

        No need to enter 1.8 and 2.0 as "fixed in" for this bug. We assume it'll stay fixed.

        Show
        Martin Dougiamas added a comment - No need to enter 1.8 and 2.0 as "fixed in" for this bug. We assume it'll stay fixed.

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: