Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-63250

RecordRTC and assignment: Players are too big

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Reopened
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.5
    • Fix Version/s: None
    • Component/s: HTML Editor (Atto), Media
    • Labels:
    • Testing Instructions:
      Hide

      Prerequisites:

      1. Site administration -> Plugins -. VideoJS player -> Limit size is set to "Yes"
      2. "Teacher T" and "Student S" are enrolled in "Course C"
      3. Make sure you are able to record a video with your testing device (at least camera needed, microphone is optional)
      4. Avoid testing with Safari as it has problems with the recordings (see e.g. MDL-62540)

      Test

      1. Login as Teacher T into Course C and turn editing on
      2. Add an assignment with the following settings to the course
        1. Assignment name: Test for video players
        2. Submission types: Online text
      3. Login as Student S, go to Course C and open the assignment "Test for video players"
      4. Click on "Add submission"
      5. Click on button "Record video"
      6. Record a short video and click on "Attach recording"
      7. Save the changes
      8. Verify that the size of the video in the table is 400 px
      9. Login again as Teacher T
      10. Go to the course and open the assignment
      11. Click on button "View all submissions"
        1. Verify that the size of the video in the table is 400 px and there are no large spaces to the left an right of the video
      12. Login as an admin and change the setting "media_videojs | limitsize" to "No"
      13. Rerun the test with the same expectations
      Show
      Prerequisites: Site administration -> Plugins -. VideoJS player -> Limit size is set to "Yes" "Teacher T" and "Student S" are enrolled in "Course C" Make sure you are able to record a video with your testing device (at least camera needed, microphone is optional) Avoid testing with Safari as it has problems with the recordings (see e.g. MDL-62540 ) Test Login as Teacher T into Course C and turn editing on Add an assignment with the following settings to the course Assignment name: Test for video players Submission types: Online text Login as Student S, go to Course C and open the assignment "Test for video players" Click on "Add submission" Click on button "Record video" Record a short video and click on "Attach recording" Save the changes Verify that the size of the video in the table is 400 px Login again as Teacher T Go to the course and open the assignment Click on button "View all submissions" Verify that the size of the video in the table is 400 px and there are no large spaces to the left an right of the video Login as an admin and change the setting "media_videojs | limitsize" to "No" Rerun the test with the same expectations
    • Affected Branches:
      MOODLE_35_STABLE
    • Pull 3.6 Branch:
    • Pull 3.7 Branch:
    • Pull Master Branch:
      MDL-63250-master

      Description

      Hi,

      while testing the new RecordRTC feature, I also tested this how it works with assignments. I setup the assignment with text submission.
      So by doing a submission, the atto opens and users can also use the video and audio recording tools in the editor.
      With a supported browser everything works well, except for the displaying of the submissions in their single / list view.

      Both, video and audio submissions are displayed way to large:
      Video:

      Audio:

      Student's view:

      Edit:
      I found out that this is a result of the setting media_videojs | limitsize
      If this setting is disabled, the player will be displayed full width.

      Nevertheless, if the setting is enabled and respects the dimensions of the settings media_default_width and media_default_height the player itself is displayed smaller but still the full width is used and a lot of whitespace in front and behind the player is still there what leads to a lot of horizontal scrolling:

      The cause is this:
      https://github.com/moodle/moodle/blob/6153be6850869cdc3a6ae925dcf6e688ac481333/filter/mediaplugin/styles.css#L12

      Just for the sake of completeness:
      Within the grading page, the displaying is fine:

      Best, Kathrin

        Attachments

          Activity

            People

            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 1 hour, 5 minutes
                1h 5m