Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-63253

Admin search results should provide location of the found matching page

    XMLWordPrintable

    Details

    • Testing Instructions:
      Hide
      1. Log in as admin
      2. Search for various strings via the admin search feature - e.g. words like "user", "lang", "setting" etc.
      3. TEST: Make sure the location of the found page within the administration tree menu is displayed below its title
      4. TEST: Make sure the location is rendered adequately to how the main breadcrumb navigation trail is rendered in the given theme and language (i.e. using the same separator between the nodes).
      5. Please test in both Clean and Boost themes, in a LTR and RTL language (such as Hebrew).

      Thanks for your time.

      Show
      Log in as admin Search for various strings via the admin search feature - e.g. words like "user", "lang", "setting" etc. TEST : Make sure the location of the found page within the administration tree menu is displayed below its title TEST : Make sure the location is rendered adequately to how the main breadcrumb navigation trail is rendered in the given theme and language (i.e. using the same separator between the nodes). Please test in both Clean and Boost themes, in a LTR and RTL language (such as Hebrew). Thanks for your time.
    • Affected Branches:
      MOODLE_35_STABLE
    • Fixed Branches:
      MOODLE_36_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-63253-master-adminsearchresults

      Description

      There is a problem I often run into when using the admin search feature. The search results page shows just the titles of the found matching pages / sections but not their location within the admin tree. In certain cases, we even have multiple admin pages with the same title - making it impossible to distinguish which is which.

      Steps to reproduce

      1. Go to https://demo.moodle.net/admin/search.php and log in as an admin
      2. Search for "general settings"
      • Expected behaviour: I should be able to uniquely identify each of matching pages / sections
      • Actual behaviour: Two "General settings" pages are found. No easy way to distinguish which is for what part of the administration tree.

        Attachments

        1. image-2018-09-26-08-50-25-759.png
          image-2018-09-26-08-50-25-759.png
          190 kB
        2. screenshot-1.png
          screenshot-1.png
          30 kB
        3. screenshot-2.png
          screenshot-2.png
          32 kB
        4. screenshot-3.png
          screenshot-3.png
          31 kB

          Activity

            People

            • Votes:
              2 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                3/Dec/18

                Time Tracking

                Estimated:
                Original Estimate - 0 minutes
                0m
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 10 minutes
                10m