Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-63271

Check for downgrades before starting upgrade

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.5.1
    • Fix Version/s: None
    • Component/s: Installation
    • Labels:
      None
    • Affected Branches:
      MOODLE_35_STABLE

      Description

      When attempting an upgrade, if one of the plugins is at a lower version than the currently installed version, the upgrade fails with a message about being unable to downgrade. It would be preferable if this were checked before the upgrade starts, to avoid partial upgrades in this scenario.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              maherne Michael Aherne
              Participants:
              Component watchers:
              Matteo Scaramuccia, Andrew Nicols, Mathew May, Michael Hawkins, Shamim Rezaie, Simey Lameze
            • Votes:
              2 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated: