Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-63313

Check Moodle core version in the Policies plugin prior and during upgrade

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: 3.3.8, 3.4.5
    • Fix Version/s: None
    • Component/s: Privacy
    • Testing Instructions:
      Hide
      1. Install Moodle 3.3.0.
      2. Install the patched plugin into the Moodle.
      3. TEST: Make sure that a warning is displayed in the privacy admin UI
      4. Update the Moodle code base to 3.3.1 or any later 3.3.x version that does not have the plugin included yet.
      5. TEST: Make sure that you can upgrade.
      6. Update the Moodle code base to the latest weekly 3.3+ which already has the plugin included. Make it in a way that the plugin's code is still the old one from the github and not the one from standard Moodle
      7. TEST: Assert that the Moodle can't be upgraded as the environment check fails.
      8. Repeat adequately with 3.4.0.
      Show
      Install Moodle 3.3.0. Install the patched plugin into the Moodle. TEST: Make sure that a warning is displayed in the privacy admin UI Update the Moodle code base to 3.3.1 or any later 3.3.x version that does not have the plugin included yet. TEST: Make sure that you can upgrade. Update the Moodle code base to the latest weekly 3.3+ which already has the plugin included. Make it in a way that the plugin's code is still the old one from the github and not the one from standard Moodle TEST: Assert that the Moodle can't be upgraded as the environment check fails. Repeat adequately with 3.4.0.
    • Affected Branches:
      MOODLE_33_STABLE, MOODLE_34_STABLE

      Description

      The Policies plugin was merged into the standard Moodle distribution in MDL-62800. So the versions 3.3.8 and 3.4.5 will be released with the plugin newly present. We want to warn the admins via the github (contrib) version of the plugin and eventually avoid the situation when the addon code would remain in recent 3.3 or 3.4 site. Only the core code should be present.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              mudrd8mz David Mudrák (@mudrd8mz)
              Reporter:
              mudrd8mz David Mudrák (@mudrd8mz)
              Peer reviewer:
              Sara Arjona (@sarjona)
              Participants:
              Component watchers:
              Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: