Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-63365

Atto modifies code in text editor once a user clicks on the "Save" button

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.4.4
    • Fix Version/s: None
    • Component/s: HTML Editor (Atto)
    • Labels:
      None
    • Affected Branches:
      MOODLE_34_STABLE

      Description

      I don't know why, but Atto injects code into my HTML editor "after" the save button has been clicked. It happens when I paste content from outside of Moodle - even if I use a paste program to remove any formatting so I know I'm pasting straight html in to the html editor and confirm my html looks good. But as soon as I click save and then edit again (for a page or assignment module), the code has changed. This concerns me because when I click that save button, I am not expecting Moodle (or Atto) to take over and add more content into my html. 

       

      This doesn't happen 100 of the time, but enough to know something seems wrong and I'm not sure if it's my site configuration or Atto itself (since TinyMCE did not do this). 

       

      Discussions with examples of similar complains: 

      https://moodle.org/mod/forum/discuss.php?d=362753#p1465055 

      https://moodle.org/mod/forum/discuss.php?d=374034

      https://moodle.org/mod/forum/discuss.php?d=375768

       

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              jprovasnik John Provasnik
              Participants:
              Component watchers:
              Andrew Nicols, Mathew May, Michael Hawkins, Shamim Rezaie, Simey Lameze
            • Votes:
              5 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: